Nextcube Probleme …

Ich habe hier einen Nextcube bei dem die Festplatte, leider, defekt ist. Von der Platte gibt es keine Sicherheitskopie. Also neue Platte rein und installieren. Aber da fängt das Problem an. Eine funktionierende 50 Polige SCSI-HD finden. Die ersten 3 waren Defekt. Die 4. funktioniert. Also rein in dem Rechner und mit der Bootdiskette und CD-Rom Nextstep 3.3 installieren.
Alles läuft gut, die Installation funktioniert bis zum Ende.
Das System booted ohne Probleme. Etwas damit testen – geht erstmal alles. Doch das Konfigurationsprogram configure meldet einen Fehler: es ist beschädigt. Hat die Festplatte doch einen Defekt?
Next_workspace
Nun habe ich nur noch 68Pollige SCSI-Festplatten vor Ort. Gut, das ich dafär einen Adapter habe. Nachdem auch da mehrere Platten Defekt waren habe ich eine 4GB HD gefunden, die auch vom Rechner erkannt wurde. Die Installation geht voran. Doch dann meldet der Rechner: 30MB Frei, Platz reicht nicht ….

Festplatte ausgebaut, in einem anderen Rechner komplett gelöscht, wieder neu eingebaut, selber Fehler.

Ein paar Tage später war ich in einem Lager und habe weitere SCSI-HD’s mitgebracht.
Darunter auch ein paar funktionierende. Wieder die selbe Prozedur mit der Installation. Alles funktioniert auch so wie beim 1. Versuch. Leider auch der selbe Fehler …

Kann da ein Leser vielleicht helfen?

Während des Testens kamm mir auch folgendes ‚Alert‘
Alert_Next

Ergänzung:
Im Verzeichnis /NextAdmin/Configure.app ist kein binary.
Deswegen habe ich das Verzeichnis gesichert und aus dem Verzeichnis /NextAdmin von der CD Configure.app kopiert. Leider gibt es beim Starten einen Bus-error. Ich fürchte das es ein Intel-Binary ist (oder gab es damals schon Multibins?)

Dieser Beitrag wurde unter Allgemein, Geschichten, Interessante Artikel veröffentlicht. Setze ein Lesezeichen auf den Permalink.

2 Antworten zu Nextcube Probleme …

  1. tr sagt:

    Hi,

    als Besitzer einer NonADB Mono-Slab seit fast 17 Jahren kann ich vielleicht etwas Hilfestellung geben 🙂

    In der Theorie sollten sich sämtliche 50- und/oder 68poligen SCSI-Festplatten verwenden lassen, in der Praxis schaut dies natürlich anders aus. Generell sollte die ’neue‘ SCSI-Platte möglichst <= 4 GB sein, mit mehr kann NeXTstep als erste (Boot-)Partition ohne wüstes Gefrickel eh nicht umgehen. Außerdem hilft es, wenn der /etc/disktab von NS 3.3 die Festplattenparameter bekannt sind (deswegen eine ältere Platte nehmen), dies kann man aber im Notfall aber auch selber erstellen. Weitere Partitionen und/oder Platten können natürlich dann nach erfolgreicher Installation ebenfalls händisch in die /etc/disktab eingetragen werden und sind dann benutzbar. Ich habe in meiner Slab seit über 12 Jahren eine IBM DORS-32160 mit 2 GB, diese wurde damals nach dem Tod der originalen 105MB-Platte ohne Probleme erkannt.

    Das eine 4GB Platte nicht reicht kann ich nicht bestätigen, der Platz sollte auf jeden Fall dicke reichen. Mir ist so (meine letzte Neuinstallation war 2001) dass man irgendwo die Installation anpassen kann (Sprachpakete, Digital Webster, Librarian etc.) – nicht dass Du versuchst sämtliche Bookshelfs in sämtlichen Sprachen usw. mit zu installieren? Was für eine Version von NS 3.3 hast Du genau? Versuchst Du die Developer Tools mit zu installieren (die sollten aber normalerweis auf einer eigenen CD sein…)?

    Bezüglich configure.app: das ist definitiv ein QuadFat-Binary und unter Next68k, Intel, HP-PA und Sparc (NIHS) universell einsetzbar (weswegen es mit configure.app auf Intel-Hardware Funktionen gibt die da gar nicht funktionieren weil der entspr. Unterbau fehlt). Woher der Bus Error (= segfault) kommt ist allerdings schwer zu sagen – stimmen die Berechtigungen (0644 afair)? Ist die CD noch in Ordnung? Machen andere Programme ebenso Probleme? Auf jeden Fall sollte nach einer Installation configure.app mit auf der Festplatte liegen.

    • Axel sagt:

      Hallo,

      erstmal danke für die Antwort!
      Bei der Installation mit der 4gb HD ist eher ein anderes Problem – die Partition passt einfach nicht, bzw die Festplatte ist um paar mb über 4gb gross ….

      Ich habe hier eine Academic-Version. Genauer kann ich gerade nicht schauen (Rechner steht woanders, komme erst nach Weihnachten ran).

      Es funktionieren alle Programme die ich getestet habe.
      Ausser configure.app – in dem entsprechendem Verzeichnis ist auch rel. wenig drinnen – und auch kein executable.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.